Cannot load save/world

Sep 4, 2014 at 7:02 PM
I get an error everytime I want to load a save. Says that it cant find a certain field.
Sandbox.Common.ObjectBuilders.MyObjectBuilder_Cockpit.Pilot - this is the missing field

2014-09-04 14:50:53,756 [1] FATAL SEToolbox.Support.DiagnosticsLogging [(null)] - Unhandled Exception
Application: C:\Program Files (x86)\MidSpace\SEToolbox\SEToolbox.exe
CommandLine: "C:\Program Files (x86)\MidSpace\SEToolbox\SEToolbox.exe"
CurrentDirectory: C:\Program Files (x86)\MidSpace\SEToolbox
SEBinPath: C:\Program Files (x86)\Steam\steamapps\common\SpaceEngineers\Bin64
ProcessorCount: 8
OSVersion: Microsoft Windows NT 6.1.7601 Service Pack 1
Version: 4.0.30319.18444
Is64BitOperatingSystem: True
IntPtr.Size: 8
IsAdmin: True
CurrentUICulture: en-US
CurrentCulture: en-US

Files:
2014-08-11T18:03:24.0000000-04:00 498,176 2014.2.17.1 HelixToolkit.Wpf.dll
2014-07-30T18:20:40.0000000-04:00 200,704 0.86.0.518 ICSharpCode.SharpZipLib.dll
2014-07-30T18:20:42.0000000-04:00 301,056 1.2.13.0 log4net.dll
2014-09-04T13:04:50.0230434-04:00 999,352 1.0.0.0 Sandbox.Common.dll
2014-09-04T13:04:50.6580797-04:00 2,873,272 1.0.0.0 Sandbox.Common.XmlSerializers.dll
2014-08-29T10:02:54.0000000-04:00 1,000,960 01.045.011.2 SEToolbox.exe
2014-07-30T18:20:40.0000000-04:00 747 SEToolbox.exe.config
2014-08-29T10:02:50.0000000-04:00 27,648 1.0.0.0 SEToolbox.ImageLibrary.dll
2014-08-29T10:02:50.0000000-04:00 7,680 1.0.0.0 SEToolbox.ImageShaders.dll
2014-08-29T10:02:54.0000000-04:00 1,932,800 SEToolbox.pdb
2014-08-29T10:02:50.0000000-04:00 48,640 1.0.0.0 SEToolboxUpdate.exe
2014-08-02T10:01:42.0000000-04:00 39,936 2.0.20525.0 System.Windows.Interactivity.dll
2014-09-04T13:04:18.1322194-04:00 665,528 1.0.0.0 VRage.Common.dll
2014-09-04T13:04:16.0320993-04:00 1,012,152 1.0.0.0 VRage.Library.dll
2014-09-04T13:04:50.9360956-04:00 359,864 1.0.0.0 VRage.Math.dll
2014-07-30T18:20:40.0000000-04:00 64,512 2.2.0 WPFLocalizeExtension.dll
2014-07-30T18:20:40.0000000-04:00 26,624 1.1.6.3 XAMLMarkupExtensions.dll

BinCachePath: C:\Users\%USERNAME%\AppData\Local\MidSpace\SEToolbox__bincache
2014-09-04T13:04:50.0230434-04:00 999,352 1.0.0.0 Sandbox.Common.dll
2014-09-04T13:04:50.6580797-04:00 2,873,272 1.0.0.0 Sandbox.Common.XmlSerializers.dll
2014-09-04T13:04:18.1322194-04:00 665,528 1.0.0.0 VRage.Common.dll
2014-09-04T13:04:16.0320993-04:00 1,012,152 1.0.0.0 VRage.Library.dll
2014-09-04T13:04:50.9360956-04:00 359,864 1.0.0.0 VRage.Math.dll

System.MissingFieldException: Field not found: 'Sandbox.Common.ObjectBuilders.MyObjectBuilder_Cockpit.Pilot'.
at SEToolbox.Models.ExplorerModel.LoadSectorDetail()
at SEToolbox.Models.ExplorerModel.<>c__DisplayClass1.<LoadSandBox>b__0() in d:\Development\SpaceEngineers\Codeplex\Main\SEToolbox\SEToolbox\Models\ExplorerModel.cs:line 418
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
Sep 4, 2014 at 8:54 PM
me too, same problem.
Coordinator
Sep 4, 2014 at 11:35 PM
Please see the open Issue on this bug.
https://setoolbox.codeplex.com/workitem/1452

If someone could supply a .zipped copy of a world that is exhibiting this issue, I would appreciate it.
Coordinator
Sep 6, 2014 at 12:58 AM
01.046.011 Release 1 should have now resolved this issue.
Marked as answer by midspace on 9/5/2014 at 5:58 PM